by

Eclipse

Varoitus, datailua!

Tilannehan oli nyt tämä, että halusin siirtyä PHPEclipsen käytöstä PHP IDE (nykyisin PDT) käyttöön. Samalla päivittyisi Eclipsekin versiosta 3.1 versioon 3.2.

Ongelmia oli kaksi. Ensinnäkin PDT ei osannut lukea vanhoja tiedostoja oikein. Ääkköset eivät näkyneet. Eclipsen irkkikanavalla neuvottiin menemään Window -> Preferences -> General -> Content Types
ja vaihtamaan PHP-tiedostojen charsetit sopiviksi. Defaulttina ne on UTF-8. Muutettuani ne ISO-8859-1, niin ääkköset palautuivat. Jee!

Seuraava murhe oli Code Assist ja Outlinet. Ne kun eivät meinanneet toimia. Kauan hakkasin päätä seinään, kunnes sattumalta eclipsen news-palvelimelta löytyi lohtu ja linkki apuun. .project tiedostoihin oli jäänyt kummittelemaan PHPEclipsen haamuja, joten homma ei tietenkään pelittänyt. Cakebakerista löytyy ohjeet, kuinka asian voi korjata.

PDT:ssä on sellaisia ominaisuuksia (parempia), joita PHPEclipsessä ei ollut ja lisäksi Eclipse 3.2 tuntuu paljon nopeammalta kuin 3.1.

Kommentoi

Comment